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Overview 
The CRM Suite is a collection of three easy-to-use implementations of CRM trial design methods for 

Phase I clinical trials. These methods are CRM, BMA-CRM, and DA-CRM. This document focuses on how 

to use the software, not the statistical methods themselves. Separate documents describe the statistical 

methods, which can be obtained from Help→BMA-CRM Method Description for BMA-CRM and 

CRM (noting that CRM is a special case of the BMA-CRM when only one model is specified) and 

Help→DA-CRM Method Description for DA-CRM: 

 
Detail showing the Help menu. 

NOTE: There are additional concepts and trial conduct rules which are not mentioned in these 

descriptions but which are implemented in this software.  Please see Appendix II – Additional Concepts 

and Rules. 

Text in bold face corresponds to text taken directly from the user interface. 
 
Text in italic bold face corresponds to either keys on the keyboard or uses of the mouse. 
 
Text in Consolas italics indicates a series of menu commands. 
 
When you start CRM Suite, you are asked to pick which of the three CRM trial design methods you 
would like to use: 

 CRM – Find MTD for single-agent trials 
Continual Reassessment Method (CRM) is a model-based Phase I trial design to find the MTD 
from a list of pre-specified dose levels. 

 BMA-CRM – An improved CRM design more robust to model misspecification 
Bayesian Model Averaging Continual Reassessment Method (BMA-CRM) allows users to specify 
multiple different shapes of dose-toxicity curves (models), and uses BMA to favor the best-fitted 
one to achieve robust decision making. CRM is a special case of the BMA-CRM when only one 
model is specified. 

 DA-CRM – Handle late-onset toxicity or fast accrual 
Data Augmentation Continual Reassessment Method (DA-CRM) allows for real-time dose 
assignment for new patients while some enrolled patients' toxicity data are still pending, 
thereby significantly shortening the trial duration compared to CRM. 

 
For each type of trial design, the CRM Suite main form has three tabs: one for specifying the trial design 

and model parameters, one for running simulations to assess operating characteristics of the trial 

design, and one for carrying out a hypothetical clinical trial using the trial design. 
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CRM Suite provides default parameters. These defaults are loaded at startup and can be reloaded from 

the File→New.  

In addition to this file, you can get help through ToolTips by hovering your mouse over things like labels 

and error indicators. 

This program is distributed at no cost to the user.  However, redistribution of this program is not 

permitted.  Each person should obtain a copy directly from The University of Texas MD Anderson Cancer 

Center at https://Biostatistics.mdanderson.org/SoftwareDownload . 

This allows us to keep a record of who may be using the software and allows us to notify all users when 

program enhancements become available. 

System Requirements 
 Windows 7 SP1 

 Microsoft .NET Framework version 4.5.2 (full framework, x86 and x64) 

 Microsoft Visual C++ 2013 Runtime Libraries (x86) 

 Windows Installer 4.5 

 Minimum Screen Resolution 1260x749 

If any of the required software components is missing, the installation procedure will install them.  

Disclaimer 
We provide absolutely no warranty of any kind expressed or implied, including but not limited to, the 

implied warranties of merchantability and fitness for a particular purpose.  The entire risk as to the 

quality and performance of the program is with the user.   

Should this program prove defective, the user assumes the cost of all necessary servicing, repair, or 

correction. 

In no event shall The University of Texas or any of its component institutions including MD Anderson 

Cancer Center be liable for damages, including any lost profits, lost monies, or other special, incidental 

or consequential damages arising out of the use or inability to use (including but not limited to loss of 

data or its analysis being rendered inaccurate or losses sustained by third parties) the program. 

 

https://biostatistics.mdanderson.org/SoftwareDownload
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1 CRM Trial Type Chooser 
When you first start CRM Suite, you select the CRM trial design that you would like to use. To do so, you 

click the button corresponding to that trial type. 

 
The CRM Trial Type Chooser. 
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2 CRM Suite Main Form 
After you click the trial design type button, the CRM Suite main form appears. 

For each type of trial design, the CRM Suite main form has three tabs: one for specifying the trial design 

and model parameters (Model Parameters), one for running simulations to assess operating 

characteristics of the trial design (Simulation Run), and one for carrying out a hypothetical clinical trial 

using the trial design (Trial Conduct). 

 
Detail of the CRM Suite main form, showing the three tabs. 

  



7 
 

2.1 Model Parameters Tab Page 

The Model Parameters tab page is where you enter the design parameters for your trial. All three trial 

types share a number of parameters, while the BMA-CRM and DA-CRM have some additional 

parameters. 

2.1.1 Common Trial Design Parameters 

 
Detail of CRM Suite main form for CRM trial designs, showing trial design parameters common to all 

three trial designs in the Model Parameters tab page. 
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Patients in Trial: 
The Maximum Sample Size is the maximum number of patients in the trial.  It must be between 1 and 

200 (inclusive) and a multiple of the Cohort Size. We recommend the maximum sample size be at least 

three times the number of dose levels; if it is lower you will be warned. 

The Cohort Size may be either 1, 2, 3, or 4. 

Dose Info: 
The Number of Doses specifies the number of dose levels in the trial.  It must be between 2 and 20, 

inclusive. 

The Starting Dose Level is the dose level at which the first cohort of patients in the trial will be treated. 

Toxicity Info: 
The Toxicity Assessment Period (Days) specifies the number of days for which each patient will be 

observed for dose limiting toxicity (DLT) after treatment. This is also known as the observation window. 

A patient must be observed for the entire toxicity assessment period without DLT in order for his or her 

outcome to be “no toxicity”. Any DLT must be observed in the toxicity assessment period; if DLT is 

observed the patient’s outcome will be “toxicity”. 

The Target Toxicity Probability is the desired probability of DLT for the Maximum Tolerated Dose (MTD).  

The trial designs implemented by CRM Suite all seek to find the MTD from a set of dose levels.  The MTD 

found will be the dose level for which the posterior probability (conditional on all data) of DLT is closest 

to the Target Toxicity Probability, subject to some conditions (see MTD Determination).  

The Safety Stopping Probability is used in stopping the trial early for safety if it appears that all dose 

levels are too toxic.  This is judged by calculating the posterior probability (conditional on the current 

data) that the lowest dose level has a toxicity probability greater than the Target Toxicity Probability.  If 

this posterior probability is greater than the Safety Stopping Probability, the trial stops early for safety.  

The Safety Stopping Probability may be set to 1.0 to effectively disable stopping the trial early for 

safety, although this is not recommended for an actual trial. 

Prior MEDIAN Probabilities of Toxicity at Each Dose: 
The bar chart allows you to specify the prior median probabilities of toxicity at each dose level. Each 

Toxicity Probability must be between 0.01 and 0.99 inclusive, and furthermore must be non-decreasing 

with dose level. The probabilities can be entered manually or adjusted up or down using the arrow 

buttons or your mouse’s scroll wheel. As you specify these probabilities they are also displayed as a line 

graph below the bar chart. The horizontal black lines are at the Target Toxicity Probability. 
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2.1.2 Trial Design Parameters for BMA-CRM Only 

For the BMA-CRM you specify multiple different Probability Sets (shapes of dose-toxicity curves or 
models), so there are some differences in the Prior MEDIAN Probabilities of Toxicity at Each Dose: 

 
Detail of the Model Parameters tab page for the BMA-CRM trial design, showing the Prior MEDIAN 

Probabilities of Toxicity at Each Dose. 

For the BMA-CRM you are allowed to specify up to 5 Probability Sets. These are specified individually by 

changing the Currently Displayed Probability Set and using the bar chart to specify the Toxicity 

Probability for each dose level. Each probability set has a unique color. This color and a unique line type 

are used in the line graph. You specify the Number of Probability Sets between 2 and 5 inclusive. If you 

wish to use only one Probability Set you must use the CRM trial design type. 
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2.1.3 Trial Design Parameters for DA-CRM Only 

For DA-CRM only you specify some additional parameters. These are in the Prior and Safety Rules 

section of the Model Parameters tab page: 

 
Detail of the Model Parameters tab page for the DA-CRM trial design, showing the Prior and Safety 

Rules section. 

The Toxicity Occurrence Prior Probabilities for the Toxicity Assessment Period specify the prior 

probabilities that a DLT will occur during each third of the Toxicity Assessment Period, conditional on a 

DLT occurring during the Toxicity Assessment Period. These thirds are called “Trimesters”. Since the 

probabilities are conditional on a DLT occurring, they must sum to 1. Because of this constraint and 

because DA-CRM is especially popular for treatments with late-onset toxicities, you specify the 

probabilities for Trimester 2 and Trimester 3. These are the time periods in the middle third and the 

final third of the Toxicity Assessment Period respectively. As you specify these probabilities the program 

will automatically ensure that all three probabilities sum to 1. These probabilities are used to specify the 

priors for the piecewise exponential hazard model; see Appendix I – Priors for the Piecewise Exponential 

Hazard Model. 

The Minimum Number of Observations at the Current Dose Level to Allow DA Escalation is an extra 

safety constraint on the Data Augmentation (DA) algorithm. When there is at least one patient outcome 

which has not been observed, and the dose level for a new cohort needs to be determined, the DA-CRM 

trial design uses the DA algorithm to determine the next dose level. If the DA algorithm recommends 

escalation, the number of observations at the current dose level is checked. If the number of 

observations is less than the Minimum Number of Observations at the Current Dose Level to Allow DA 

Escalation the trial will wait (for more information to be recorded) rather than escalate the dose level, 

accrue a patient, and treat a cohort at the escalated dose level. If the Minimum Number of 

Observations at the Current Dose Level to Allow DA Escalation is set to 0 this effectively disables this 

extra safety rule. 
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2.2 Simulation Run Tab Page 

The Simulation Run tab page is used to simulate the clinical trial designed in the Model Parameters tab 

page in order to obtain the operating characteristics of the trial design under different assumptions 

about the treatment’s probabilities of DLT at each dose level, time to DLT occurrence in the Toxicity 

Assessment Period, and patient accrual rate. This is done by conducting trials using your design with 

randomly simulated virtual patients. Many such simulated trials are conducted using each scenario and 

the results are averaged for each scenario, producing the operating characteristics or expected behavior 

of the trial for that scenario. 

Note that the Simulation Run tab page is the same for all CRM Suite designs (CRM, BMA-CRM, and DA-

CRM). 
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Detail showing the Simulation Run tab page’s input controls. 
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2.2.1 Simulation Input 

Number of Simulated Trials specifies the number of randomly simulated (virtual) trials that will be 

conducted per scenario when the Simulate button is pushed. This is also the number over which data 

are averaged to obtain the operating characteristics for each scenario for the Simulation Output. Thus a 

larger number corresponds to a longer time spent simulating to prepare the Simulation Output report, 

but less variable operating characteristics. 

Seed is the random number generator seed. It can be changed to examine the effect of randomness on 

the operating characteristics; changing it only affects the random number generator used to simulate 

patient arrival and outcomes. 

Proportion of Toxicities Observed in Second Half of Assessment Period is the proportion of simulated 

DLTs which will be observed in the second half of the Toxicity Assessment Period as opposed to the first 

half. DLT times are simulated using a Weibull distribution; this distribution is parameterized for each 

dose level in a scenario by the probability of toxicity specified for that dose level and the Proportion of 

Toxicities Observed in Second Half of Assessment Period.  

The Accrual Rate (Patients per Month) is the accrual rate used in the simulations to simulate patient 

arrivals. In the simulations virtual patients are simulated as having a Poisson arrival process, 

parameterized by this rate. Note that the unit is patients per month. 

Scenarios may be specified in the table below the Delete Scenario and Add Scenario buttons. The 

scenarios consist of the “true” probabilities of DLT at each dose level in the trial design. These 

probabilities will be used to randomly determine the outcomes for the virtual patients treated in the 

simulated trials. In this way you can assess the operating characteristics of your trial design in a variety 

of circumstances, from an unexpectedly safe treatment to a dangerously toxic treatment and many 

other variations. These “true” DLT probabilities are specified in the “Probability” column. Each scenario 

has a name in the “Scenario” column. To change the DLT probabilities or the scenario names, click twice 

on the value you want to change to select it and enter a new value or edit the current value. 

The table’s background color alternates between scenarios. Scenarios can be added by clicking the “Add 

Scenario” button. After selecting a scenario by clicking on it in the table, the scenario can be moved in 

the list by clicking the “up arrow” and “down arrow” buttons. It can also be deleted by clicking the 

“Delete Scenario” button. There must be at least one scenario specified however. The order of the 

scenarios in the table is the order they are presented in the simulation output. 
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2.2.2 Simulation Output 

To run a set of simulations, click the Simulate button. While the simulations are running, the progress 

bar grows. Simulations may be stopped by clicking the Abort button. If the simulations are aborted, 

partial results are reported. 

 
Detail of the Simulation Run tab page showing simulations running and the Abort button enabled. 

When the simulations are finished, a simulation report appears. 
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Detail of the Simulation Run tab page showing the top of a simulation report and the Simulate button 

enabled. 

The simulation report contains the trial design specified on the Model Parameters tab page, followed by 

the simulation settings, and then the scenarios with their operating characteristics. 

Note that the program can be resized larger by grabbing the lower right corner and dragging it. This will 

make the area displaying the simulation report larger, which may make it easier to read. Also note that 

parts of the simulation report, or the entire report, may be selected and copied for pasting into other 

programs such as Microsoft Word or an email message. 

A complete sample DA-CRM Simulation Output report can be found in Appendix III – Sample Simulation 

Output. 
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2.3 Trial Conduct Tab Page 

The Trial Conduct tab page can be used to conduct an individual hypothetical trial using your design: 

 
The Trial Conduct tab page. 
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2.3.1  Editing Dose Descriptions 

To get started conducting your trial, click the Edit Dose Descriptions button. This brings up a dialog 

allowing you to give descriptions for each of the doses. These descriptions will be saved and will be used 

in the conduct of the trial. NOTE: These descriptions do not affect the statistical calculations or the 

conduct of the trial in any way. They are purely descriptive, but may be helpful during trial conduct. 

 
The Edit Dose Descriptions dialog, showing the dose descriptions being edited. 

Once the trial begins, the dose level descriptions may not be changed, but they may be displayed. The 

Edit Dose Descriptions button changes to a Display Dose Descriptions button. 
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2.3.2 Getting a Decision 

To actually start conducting your trial, you need to add a patient. To add a patient, you need to know at 

which dose level to treat that patient. To do this you “get a decision” by clicking the Get Decision (Add 

Patient) button. In general as you conduct your trial you need to know what the next action to take is. 

Determining this is called “getting a decision”. When you click the Get Decision (Add Patient) button the 

“Get Decision” dialog appears: 

 
The Get Decision dialog showing that the next step in this trial is to treat the first patient at the starting 

dose level. The date chooser for the Date for the Decision and the Add Patient and Cancel buttons are 

circled in blue. 

It is important to note that each decision happens at a particular date. This date is chosen in the lower 

left corner. Any date can be used, and the calculated decision is updated whenever the date is changed. 

If the date is not before any patient treatment or outcome or last updated date for any patient, and if 

the calculated decision allows it, the Add Patient button in the lower right corner is enabled; otherwise 

it is disabled. 

By changing the date you can examine decisions for previous dates in the history of your trial, 

potentially answering questions like, “What if we had waited?” or “What if a patient had been added 

earlier?” If instead you decide to add a patient, the date is also the patient’s treatment date. 

The decision for the date in question is displayed in short form at the top of the dialog. It is displayed in 

a longer form with much more detail and explanation in the Details: panel. 
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If the decision allows it and if the Date for the Decision is appropriate, a patient may be added to the 

trial and the Add Patient button is enabled. Note that if you decide to add a patient, the Date for the 

Decision is also the patient’s treatment date. 

Note that sometimes the trial must wait for additional data before a patient may be added, and 

sometimes the trial may stop early for safety. In these cases as well as when the trial is complete, the 

Add Patient button is disabled since it is not allowed to add a patient. 

If you simply want to dismiss the dialog without adding a patient, click the Cancel button in the lower 

right corner or the “red X” button in the upper right corner. 
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2.3.3 Adding a Patient 

If you’ve decided to add a patient and have gotten an appropriate decision at the appropriate date, click 

the Add Patient button on the Get Decision dialog. This brings up the Add New Patient dialog: 

 
The Add New Patient dialog. 

You may specify the Patient ID; it must be an integer which does not identify any other patients already 

in the trial. If the ID is not acceptable an error message will appear in the Input Validating Status panel. 

The Cohort number is determined by the patient’s accession and the Dose Level is determined by the 

trial design in the Get Decision dialog. These cannot be changed. Likewise the Treatment Date was 

specified in the Get Decision dialog and can’t be changed in the Add New Patient dialog. If you wish to 

change this date you should click the Cancel button and pick a different date on the Get Decision dialog. 

This allows the date and the decision to be checked to be sure they are appropriate for patient addition. 

The Outcome Date and Toxicity Outcome must be specified and must be valid. The Outcome Date is 

either the date that the outcome was observed if it has been observed, or it is the last date that the 
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patient was assessed for DLT if the Toxicity Outcome is pending. Due to this there are some constraints 

on these data. The Outcome Date may not be earlier than the Treatment Date. If the Toxicity Outcome 

is pending or Yes (toxicity) the Outcome Date must be within the Toxicity Assessment period. 

Otherwise if the Toxicity Outcome is No (no toxicity) the Outcome Date must be the last day of the 

Toxicity Assessment Period or after it is over. To help specify these dates for hypothetical trials the 

beginning and ending dates for the Toxicity Assessment Period for this patient are displayed in the 

middle of the dialog. 

Immediately after adding a patient in a real trial the patient’s Outcome Date will be the Treatment Date 

and the Toxicity Outcome will be pending since nothing has been observed yet. 

The patient data may be edited as the trial progresses (see below). 
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2.3.4 A Trial in Progress 

The current patient data (the patient log) is displayed in the Patients panel of the Trial Conduct tab 

page. 

NOTE: While there are patients in the trial, you can NOT modify the trial design. If you wish to modify 

your design you must first delete all the patients (see below). 

 
The Trial Conduct tab page showing a trial in progress with 15 patients enrolled. 

For each patient all the data are displayed in the columns of the table in the Patients panel. Note that 

the last column is special; it contains a button for each patient. Clicking this button shows the decision 

that was made (or should have been made) when that patient was added and treated in the Display 

Decision dialog. It determines the decision based on the data in the trial as of the decision date, so if for 

example errors in the data which were present when the patient was treated but which have been 

subsequently corrected may affect the displayed decision: 
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The Display Decision dialog. 

To get a decision and possibly add a patient you can click the Get Decision (Add Patient) button on the 

Trial Conduct tab page or you can right-click the patient table to bring up a menu of this and other 

options: 
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Detail of the Trial Conduct tab page showing the menu that appears when the table in the Patients 

panel is right-clicked. 

Note that although you wish to add a patient, this may not be possible. Sometimes the trial must wait 

for additional data before a patient may be added, and sometimes the trial may stop early for safety. 

To update or change a patient’s data, right-click on the patient’s record (row) in the Patients table in the 

Trial Conduct tab page, and select Edit Selected Patient…. This brings up the Edit Patient dialog: 
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The Edit Patient dialog. Note that it is essentially identical to the Add New Patient dialog. 

The next menu option is Get Decision (Add Patient)…. Clicking this option is identical to clicking the Get 

Decision (Add Patient) button. 

Clicking the Delete Last Patient option immediately deletes the last patient added to the trial. This is 

very handy for exploring hypothetical questions and can also be used to correct the patient’s Treatment 

Date if it were specified incorrectly. The only way to delete an individual patient is to delete the last 

patient. If you wish to delete a patient who was added before the last patient you will need to delete 

the last patient repeatedly until the desired patient is deleted. 

Clicking the Delete ALL Patients… option will delete all the patients in the trial. Before this happens you 

will be asked to confirm this action. This is the only way to allow the trial design to be modified. It is also 

handy for conducting additional hypothetical trials starting from the first patient. 
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2.3.5  A Completed Trial 

When the maximum sample size has been reached by adding the maximum number of patients, the trial 

is complete. When this happens the Get Decision (Add Patient) button changes to Get Decision (View 

the MTD) and clicking it displays the MTD which has been selected as well as the data and other 

considerations which led to it being selected: 

 
The Get Decision dialog for a completed trial. Note that the decision is to stop the trial since it is 

complete and Dose 1 has been selected as the MTD, as described in the Details panel. 
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3 Saving and Opening Files  
 Program input (model parameters and scenarios) and output (simulation results), and Trial Conduct 
information if applicable, are saved in a single HTML file from the File→Save menu. 

 
Detail showing the File menu.  

This HTML file can be viewed and printed from any web browser. 

If this file is opened via the File→Open… or the File→Recent Files menu, the program input and 

any trial conduct information is restored and the simulation results appear in the Simulation Output 

window. 

If you desire to modify an existing trial design, but do not want to overwrite the existing trial design’s 

file, choose File→Save As… and choose a new file name. 

3.1 Data, Report, and File Status 

The status bar at the bottom of the program window shows three timestamps. 

 
Detail showing the status bar with the three timestamps. 

Data Changed is the last time any input parameter or any trial conduct data changed. 

Report Generated is the last time simulations were run. 

Data Saved is the last time the file was saved. 

These timestamps can help you determine if you should re-run your simulations or save your file. If you 

have anything unsaved the program will ask you if you want to save it before you do anything which will 

cause it to be lost. 
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4 Input Validation and Errors  
 If you cause an error when inputting something the program will let you know and generally won’t let 
you continue until the mistake is corrected. For example, most inputs are only valid in a certain range 
(such as between 0 and 1) and must be of the appropriate type (such as numeric). 
If there is a problem with the input the program will display an error indicator, which is a red ball with a 

white exclamation point in it: 

  
Detail showing an error indicator, in this case because the Cohort Size of 5 is larger than the maximum 

allowed value of 4. 

By hovering the mouse pointer over the red dot a small box will pop up explaining the error: 
 

 
Detail showing the explanation for the error, in this case because the Cohort Size of 4 is not a multiple of 

the Maximum Sample Size of 30. 
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Appendix I – Priors for the Piecewise Exponential Hazard Model 
The piecewise exponential hazard model used in this program has 6 pieces. See Help→DA-CMR 

Method Description for more information on the model and notation. In this program, to obtain the 

hyperparameters of the Gamma priors on the hazards we start with the probabilities that given a DLT 

occurs in the Toxicity Assessment Period, it occurs in the first, second, and last third. These are specified 

in the Toxicity Occurrence Prior Probabilities for the Toxicity Assessment Period as “Trimester 1,” 

“Trimester 2,” and “Trimester 3.”  In this appendix we denote these probabilities as 

𝑝1, 𝑝2, 𝑝3, where 𝑝1 + 𝑝2 + 𝑝3 = 1. 

We then define for the 6 pieces: 

𝑞0 = 0 

𝑞1 =
𝑝1
2

 

𝑞2 = 𝑝1 

𝑞3 = 𝑝1 +
𝑝2
2

 

𝑞4 = 𝑝1 + 𝑝2 

𝑞4 = 𝑝1 + 𝑝2 +
𝑝3
2

 

𝑞6 = 𝑝1 + 𝑝2 + 𝑝3 

For numerical reasons we actually use 

𝑞6 = 0.99 

Instead of the theoretically correct 1.0. 

From here we have for the 𝑘𝑡ℎ piece, using the lambda notation in See Help→DA-CMR Method 

Description: 

𝑒−
𝜆𝑘𝑇

6 =
1−𝑞𝑘

1−𝑞𝑘−1
, 

which can be solved to give 

𝜆𝑘 = −
6

T
ln (

1 − 𝑞𝑘
1 − 𝑞𝑘−1

) . 
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Appendix II – Additional Concepts and Rules 
The CRM, BMA-CRM, and DA-CRM trial designs are described in publications accessible through 

Help→BMA-CRM Method Description for BMA-CRM and CRM (noting that CRM is a special case of 

the BMA-CRM when only one model is specified) and Help→DA-CRM Method Description for DA-

CRM. However, these publications don’t cover some additional concepts and rules used by this program. 

These things were added for practical reasons, including safety, efficiency, investigators’ expectations, 

and actual practice. 

Look Ahead Rule 

In general during the conduct of CRM and BMA-CRM trials, all patient outcomes need to be observed 

before the next trial conduct decision can be acted on. For example, determining the dose level for the 

next cohort generally requires all patient outcomes to be known and used. 

During the conduct of CRM and BMA-CRM trials it is sometimes allowed to ignore the fact that some 

patient data are unobserved. In some circumstances the next decision in trial conduct will not be 

affected by the unobserved patient outcomes when they do become known. In particular it is 

sometimes the case that while the patients’ outcomes may affect the calculated posterior probabilities, 

they will not affect them enough to change the next recommended dose level or whether the trial will 

stop early for safety or not. Determining whether or not any unobserved patient outcomes might affect 

the next trial conduct decision is called “looking ahead”. 

The “Look Ahead Rule” says that if “looking ahead” shows that the unobserved patient outcomes will 

not affect the next trial conduct decision, then that decision should be acted on rather than waiting for 

the patient outcomes to be observed. 

Note that these considerations do not apply to DA-CRM, since the whole point of the DA-CRM is to act in 

the face of unobserved patient outcomes, particularly when those outcomes might well affect the next 

decision. 

Tried and Untried Dose Levels, and Skipping Untried Dose Levels 

When discussing dose escalation and MTD determination we distinguish between “tried” and “untried” 

dose levels. A dose level is considered “tried” if at least one patient has been treated at that dose level 

and that patient’s outcome has been observed. All dose levels below the Starting Dose Level are 

considered “tried”. If a dose level is not considered “tried” it is considered “untried”. When escalating 

the current dose level it is not allowed to escalate to a dose level for which any lower dose level is 

“untried”. Escalating to a dose level higher than an untried dose level is called “skipping an untried dose 

level”. This is not allowed. Because of this restriction, the next recommended dose level, and even the 

MTD, may not be the dose level whose posterior probability of DLT (conditional on the data) is closest to 

the Target Toxicity Probability. 

In some circumstances a dose level may be considered “tried” if at least one patient has been treated at 

the dose level but no outcomes have been observed at that dose level. This can occur in dose levels 

below the Starting Dose Level, when the Look Ahead Rule (see Look Ahead Rule) has determined that 

the unknown outcome or outcomes will not affect trial conduct, in DA-CRM if the Minimum Number of 

Observations at the Current Dose Level to Allow DA Escalation is set to zero, and so on. In every case in 
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which such a dose level is considered “tried,” there are other reasons that escalating beyond that dose 

level is acceptable. 

MTD Determination 

After the trial is finished, assuming it did not stop early for safety, the Maximum Tolerated Dose (MTD) 

is determined. This is the dose level whose posterior probability of Dose Limiting Toxicity (DLT) is closest 

to the Target Toxicity Probability subject to some constraints.  

The MTD found will be the dose level for which the posterior probability (conditional on all data) of DLT 

is closest to the Target Toxicity Probability, without skipping untried dose levels (see Tried and Untried 

Dose Levels, and Skipping Untried Dose Levels).  The MTD selected must also have had at least three 

patients treated on it. If the dose level closest to the target probability of toxicity without skipping 

untried dose levels has had fewer than three patients treated on it, the highest dose level lower than 

this dose level which has had at least three patients treated on it is determined to be the MTD. If no 

such dose level exists, the MTD is determined to be the dose level closest to the target probability of 

toxicity without skipping untried dose levels, but you are warned that the determination of the MTD has 

a high degree of uncertainty because there were too few patients treated at that dose level. 

Extra Dose Escalation Rules 

All CRM-type trials (CRM, BMA-CRM, and DA-CRM) will recommend escalation if the posterior 

probabilities of toxicity computed with the current data indicate that a higher dose level is closer to the 

Target Toxicity Probability than the current dose level. This process is described in the corresponding 

publications and method descriptions. 

However due to safety considerations and to better match investigators’ expectations and actual 

practice, the methods implemented in this software have additional constraints on dose escalation not 

described in the publications. 

First, the CRM and BMA-CRM do not allow untried dose levels to be skipped while escalating (see Tried 

and Untried Dose Levels, and Skipping Untried Dose Levels). Note that the design of DA-CRM prevents 

such skipping. 

Secondly for any of the CRM trial designs we do not allow escalation away from a dose level for which 

the raw proportion of toxicities is above the Target Toxicity Probability. That is to say, if the proportion 

of toxicities among all fully observed patient outcomes at a dose level is above the Target Toxicity 

Probability, we do not allow escalation beyond that dose level. If escalation would otherwise be 

recommended but this rule applies, it is still recommended to treat a patient, but the dose level on 

which the patient should be treated is lower than it would otherwise be. 

In addition to the current dose level, this rule applies to dose levels between the current dose level and 

the dose level to which escalation is otherwise recommended, if any. 

Note that in the rare circumstance that this rule needs to be applied to a dose level at which no patient 

outcomes have been fully observed, it is assumed that the dose level does not have a raw proportion of 

toxicities above the target probability of toxicity. This is because this rare circumstance should only arise 

with trial designs which assume for other reasons that escalating away from such a dose level is 

acceptable. 
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Appendix III – Sample Simulation Output 
Here is an example of the Simulation Output for a DA-CRM trial: 

CRM Suite version 1.0.0 

Model 

Target Toxicity Probability 0.300 

Safety Stopping Probability 
(Upper Limit Pr(tox) at Lowest Dose) 

0.900 

Maximum Sample Size 30 

Cohort Size 3 

Starting Dose Level 1 

Toxicity Assessment Period (Days) 42 

Use Data Augmentation (DA) True 

Toxicity Occurrence Prior Probabilities (Trimester 1) 0.050 

(Trimester 2) 0.150 

(Trimester 3) 0.800 

Minimum Number of Observations at the 
Current Dose Level to Allow DA Escalation 

2 

Prior Median Probabilities of Toxicity at Each Dose Level: 

Dose Prob.  

1 0.100 

2 0.210 

3 0.240 

4 0.300 

5 0.350 

 

Simulation Settings 

Number of Simulated Trials 1000 

Random Number Generator Seed 1052 

Accrual Rate (Patients per Month) 3.38 

Proportion of Toxicities Observed in 
Second Half of Assessment Period 

0.500 
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Scenarios and Results 

Scenario: High toxicity 

Dose Level True Prob(tox) Selection Probability  # of Subjects Treated # of Toxicities 

1 0.300 0.62 20.7 6.2 

2 0.400 0.19 5.8 2.3 

3 0.500 0.03 1.1 0.5 

4 0.700 0.00 0.2 0.1 

5 0.900 0.00 0.0 0.0 

Probability of Early Termination: 0.13 

Toxicities per Trial: 9.2 

Total Trial Time (Months): 9.90 

 

Scenario: Target @ 2 

Dose Level True Prob(tox) Selection Probability  # of Subjects Treated # of Toxicities 

1 0.150 0.17 11.9 1.8 

2 0.300 0.54 11.2 3.3 

3 0.400 0.22 4.9 1.9 

4 0.500 0.06 1.6 0.8 

5 0.700 0.01 0.2 0.2 

Probability of Early Termination: 0.01 

Toxicities per Trial: 7.9 

Total Trial Time (Months): 11.24 

 

Scenario: Target @ 4 

Dose Level True Prob(tox) Selection Probability  # of Subjects Treated # of Toxicities 

1 0.050 0.00 6.2 0.3 

2 0.100 0.05 5.8 0.6 

3 0.200 0.26 7.7 1.5 

4 0.300 0.40 6.7 2.0 

5 0.450 0.29 3.6 1.6 

Probability of Early Termination: 0.00 

Toxicities per Trial: 6.1 

Total Trial Time (Months): 12.77 
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Scenario: Below target 

Dose Level True Prob(tox) Selection Probability  # of Subjects Treated # of Toxicities 

1 0.000 0.00 5.0 0.0 

2 0.050 0.00 4.2 0.2 

3 0.100 0.03 5.1 0.5 

4 0.150 0.15 6.0 0.9 

5 0.200 0.82 9.8 2.0 

Probability of Early Termination: 0.00 

Toxicities per Trial: 3.5 

Total Trial Time (Months): 13.53 

 

Scenario: Above target 

Dose Level True Prob(tox) Selection Probability  # of Subjects Treated # of Toxicities 

1 0.500 0.14 16.3 8.1 

2 0.700 0.00 0.8 0.6 

3 0.800 0.00 0.0 0.0 

4 0.900 0.00 0.0 0.0 

5 0.950 0.00 0.0 0.0 

Probability of Early Termination: 0.78 

Toxicities per Trial: 8.7 

Total Trial Time (Months): 6.26 

 

Elapsed time: 3 minutes, 42 seconds  

BackEnd version 1.0.0 

Report time: Thursday, October 25, 2018 3:27:16 PM 
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Appendix IV – Power User Features for DA-CRM 
There are some settings which are intentionally made somewhat obscure and which are intended for 

power users who are debugging Data Augmentation calculations. We don’t recommend regular users 

use these features. Enabling them involves editing the input file, which is also not recommended for 

regular users. 

Background 

The Data Augmentation (DA) calculation are stochastic and in many ways are similar to MCMC decisions. 

As such there is a tradeoff between the amount of CPU time that is needed to do the calculation and the 

precision of the calculation. Very lengthy DA calculations are not desirable in simulations because of the 

huge number of calculations which must be performed. Imprecise stochastic calculations are not 

desirable in actual trial conduct, since these can lead to different trial conduct decisions without any 

change in the data. 

The DA calculations use parameters which are essentially identical in meaning to the corresponding 

parameters used in MCMC such as burn-in, thinning, and the number samples retained. Additionally 

there are some parameters which are unique to this program; describing these is beyond the scope of 

this document. 

We did extensive research to determine good values for these parameters when simulating, and when 

conducting a trial. In both situations the DA calculations should not affect the results obtained – the 

operating characteristics for simulations, and the trial conduct decision for trial conduct. 

For trial conduct, while the trial conduct decisions should be repeatable in all cases, the actual 

probabilities of DLT calculated for the dose levels and the probability calculated that the lowest dose 

level is more toxic than the target are generally not. There is some random noise in these estimates 

which does not affect the trial conduct decision. In order to prevent needless confusion, we do not 

display these probabilities calculated using Data Augmentation. However sometimes they are useful for 

debugging, so we made it possible for power users to make the program display those estimates. 

Display Data Augmentation Estimates of Probabilities 

In order to have the program display these estimates, you must save the input file and then open it in a 

text editor. Locate the line that looks like this: 

      <DisplayDADecisionEstimates>false</DisplayDADecisionEstimates> 

And change it to: 

      <DisplayDADecisionEstimates>true</DisplayDADecisionEstimates> 

Save the file and then open it in CRM Suite.  Now whenever a Data Augmentation decision is made you 

will see the probabilities of toxicity displayed by CRM Suite. Please be aware that minor variations in 

these estimates, and even sometimes large variations, may not affect the trial conduct decision which 

has been determined. 
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Get Decision dialog displaying the Data Augmentation estimates of the probabilities of toxicity at each 

dose and the probability that the lowest dose is more toxic than the target. 

DA Decision Diagnostics Dialog 

Similarly, it is sometimes useful to research how the Data Augmentation parameters affect the DA 

calculations which are performed conditional on the data in a trial. We have produced a special dialog to 

enable this research, but it is not available by default.  To enable it, you must save the input file and 

then open it in a text editor. Locate the line that looks like this: 

  <DADiagnosticsButtonVisible>false</DADiagnosticsButtonVisible> 

And change it to: 

  <DADiagnosticsButtonVisible>true</DADiagnosticsButtonVisible> 

Save the file and then open it in CRM Suite.  Now on the Trial Conduct tab an additional button appears: 

Get DA Diagnostics. 
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Trial Conduct tab page with Get DA Diagnostics button visible. 

Clicking the Get DA Diagnostics button opens the Diagnose DA Decision dialog. This dialog allows you to 

examine the results of repeating a DA calculation for your current trial with the current DA parameters 

and different DA parameters. Summary statistics of the calculations are provided so you can assess the 

adequacy of the DA parameters. The parameters you specify can also be saved for use with the trial in 

question. Further details about this dialog are beyond the scope of this document. 
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The Diagnose DA Decision dialog. 


